avatar
Brocolling's Blog

코딩테스트 준비 - N과 M(11)

혼자서 다시푸는 코딩테스트 준비 일지 - 72
백트래킹DFS
19 days ago
·
5 min read

다시푸는 코딩 테스트 준비 일지

  • 응시 사이트 : BOJ

  • 문제 : 15665.N과 M(11)

  • 사용언어 : C#

  • 난이도 : Middle

  • 풀이시간 : 10m

  • 유형 : 백트래킹 , DFS

문제

N개의 자연수와 자연수 M이 주어졌을 때, 아래 조건을 만족하는 길이가 M인 수열을 모두 구하는 프로그램을 작성하시오.

  • N개의 자연수 중에서 M개를 고른 수열

  • 같은 수를 여러 번 골라도 된다.

입력

첫째 줄에 N과 M이 주어진다. (1 ≤ M ≤ N ≤ 7)

둘째 줄에 N개의 수가 주어진다. 입력으로 주어지는 수는 10,000보다 작거나 같은 자연수이다.

출력

한 줄에 하나씩 문제의 조건을 만족하는 수열을 출력한다. 중복되는 수열을 여러 번 출력하면 안되며, 각 수열은 공백으로 구분해서 출력해야 한다.

수열은 사전 순으로 증가하는 순서로 출력해야 한다.

예제 입력 1 복사

3 1
4 4 2

예제 출력 1 복사

2
4

예제 입력 2 복사

4 2
9 7 9 1

예제 출력 2 복사

1 1
1 7
1 9
7 1
7 7
7 9
9 1
9 7
9 9

예제 입력 3 복사

4 4
1 1 2 2

예제 출력 3 복사

1 1 1 1
1 1 1 2
1 1 2 1
1 1 2 2
1 2 1 1
1 2 1 2
1 2 2 1
1 2 2 2
2 1 1 1
2 1 1 2
2 1 2 1
2 1 2 2
2 2 1 1
2 2 1 2
2 2 2 1
2 2 2 2

문제 풀이 접근

이 문제의 경우, 크게 어려운 부분은 없었다.
나를 다시 뽑아도 되고, 오름차순이며, 중복 순열의 경우 필터링을 한다. 라는 쉬운 조건을 가지고 있어서,
cnt를 pos로 잡았고, pos가 결국 뽑은 숫자를 의미하니까, 그 배열에 _arr의 i번째 값을 순회해주면, 원하는 값이 들어가게 된다.

이후 Console.Write과 같은 출력부분을 최적화 하기 위해 StringBuilder를 사용해 메세지를 담아주었고, 최종적으로 마지막에 한번만 출력하는 것으로 최적화했다.

작성 코드 (C#)

using System;
using System.Collections;
using System.Collections.Generic;
using System.Xml.Linq;
using static CodingTestProj.Program;
using System.Text;

///*
// * Difficulty : Middle
// * URL : https://www.acmicpc.net/problem/15665
//  * Time : 10m
// */

namespace CodingTestProj
{
    internal class Program
    {
        static void Main(string[] args)
        {
            Solution solu = new Solution();
            solu.solve();
        }
    }

    public class Solution
    {
        public const int _max = 8;
        public int _n;
        public int _m;
        public int[] _arr;
        public bool[] _visit;

        public StringBuilder _sb;
        public HashSet<string> _hs;

        public void solve()
        {
            _hs = new HashSet<string>();
            string[] _input = Console.ReadLine().Split(' ');

            _n = int.Parse(_input[0]);
            _m = int.Parse(_input[1]);

            _input = Console.ReadLine().Split(' ');
            _visit = new bool[_max];
            _sb = new StringBuilder();
            _arr = new int[_n];
            int[] _per = new int[_m];

            for (int i = 0; i < _arr.Length; ++i)
                _arr[i] = int.Parse(_input[i]);

            Array.Sort(_arr);

            BT(0, ref _per);
            Console.Write(_sb.ToString());
        }

        public void BT(int pos, ref int[] _c)
        {
            if (pos == _m)
            {
                string _s = string.Empty;
                for (int i = 0; i < pos; ++i)
                {
                    _s += _c[i];

                    if (i != pos - 1)
                        _s += ' ';
                }

                if (_hs.Contains(_s) == false)
                {
                    _hs.Add(_s);
                    _sb.AppendLine(_s);
                }
            }
            else
            {
                for(int i = 0; i < _n; ++i)
                {
                    _c[pos] = _arr[i];

                    BT(pos + 1, ref _c);
                }
            }
        }
    }
}

코드 결과

2411

- 컬렉션 아티클






Dotorings,