브루트포스
다시푸는 코딩 테스트 준비 일지
문제
어떤 자연수 N이 있을 때, 그 자연수 N의 분해합은 N과 N을 이루는 각 자리수의 합을 의미한다. 어떤 자연수 M의 분해합이 N인 경우, M을 N의 생성자라 한다. 예를 들어, 245의 분해합은 256(=245+2+4+5)이 된다. 따라서 245는 256의 생성자가 된다. 물론, 어떤 자연수의 경우에는 생성자가 없을 수도 있다. 반대로, 생성자가 여러 개인 자연수도 있을 수 있다.
자연수 N이 주어졌을 때, N의 가장 작은 생성자를 구해내는 프로그램을 작성하시오.
입력
첫째 줄에 자연수 N(1 ≤ N ≤ 1,000,000)이 주어진다.
출력
첫째 줄에 답을 출력한다. 생성자가 없는 경우에는 0을 출력한다.
예제 입력 1 복사
216
예제 출력 1 복사
198
문제 풀이 접근
이 문제를 잘 읽어보면, 245 => 245 + 2 + 4 + 5 는 곧 256이 된다.
고로 245는 256의 생성자이다.
고로 이문제는 어떠한 자연수 N이 주어질 때, N을 제외한 1까지의 수를 모두 순회하면서 분해합이 조건이 성립하는지, 성립한다면 제일 작은것인지 체크하면서 탐색은 N -> 1까지 완전히 순회하면서 새롭게 갱신해야 하기 때문에, 중간에 분해합 조건에 맞는다고해서 break를 주진 않고 계속해서 갱신해나갔다.
정답 작성 코드 (C#)
using System;
using System.CodeDom;
using System.Collections.Generic;
using System.ComponentModel;
using System.ComponentModel.Design;
using System.Diagnostics;
using System.IO;
using System.Linq;
using System.Reflection;
using System.Runtime.CompilerServices;
using System.Runtime.InteropServices;
using System.Security.AccessControl;
using System.Security.Authentication;
using System.Security.Cryptography;
using System.Security.Cryptography.X509Certificates;
using System.Text;
using System.Threading;
using System.Threading.Tasks;
using System.Web;
using System.Xml.Linq;
using static CodingTestProj.Program;
/*
* Difficulty : Easy
* URL : https://www.acmicpc.net/submit/2231/84909751
* Time : 미측정
*/
namespace CodingTestProj
{
internal class Program
{
static void Main(string[] args)
{
int input = Int32.Parse(Console.ReadLine());
int ret = 0;
for (int i = input - 1; i > 0; --i)
{
int divSum = 0;
for (int j = 0; j < i.ToString().Length; ++j)
{
char ss = i.ToString()[j];
divSum += Int32.Parse(ss.ToString());
}
divSum += i;
if (divSum == input)
{
ret = i;
}
}
Console.WriteLine(ret);
}
}
}